2219 図面編集
配管サポート製作図の編集操作概要
機能
-
サポート図編集における対話操作は、サポートDataを変更修正するものではなく、サポート製作図情報を編集するものです。
-
編集対象となるサポート製作図情報は、文字記号情報(ラインマーク、寸法など)の位置移動、任意文字・図形等の追加編集等の情報です。
「任意文字・図形」については組図、スプール図、サポート図で共通の操作となります。「13-15 任意文字・図形(共通)」を参照してください。
操作及び処理
編集対象文字記号情報とレイヤ
編集していない初期のサポート製作図は、寸法位置等が自動配置されます。(旧msupt.exeと同じ)
編集対象となる情報は、予めMsuptGuiによりレイヤで表示設定を行う必要があり、図面出力されない文字記号情報は編集できません。
編集対象となる文字記号情報は以下の通り。
| No | 文字・図形情報 | 編集Mode | 移動タイプ | 事例Page |
|---|---|---|---|---|
| 1 | アタッチメント詳細図 | 文字情報編集 | 任意 | アタッチメント詳細図(移動方向:任意) |
| 2 | U-ボルト穴詳細図 | 文字情報編集 | 任意 | U-ボルト穴詳細図(移動方向:任意) |
| 3 | コメント | 文字情報編集 | 任意 | コメント(移動方向:任意) |
| 4 | スタイル | 文字情報編集 | 任意 | スタイル(移動方向:任意) |
| 5 | 北方向マーク | 文字情報編集 | 任意 | 北方向(移動方向:任意) |
| 6 | サポート高さ/固定部高さ | 文字情報編集 | 引出方向のみ | サポート高さ/サポート固定部高さ(移動方向:引出方向) |
| 7 | 面取り記号 | 文字情報編集 | 引出方向のみ | 面取り記号(移動方向:引出方向) |
| 8 | ラインマーク | 文字情報編集 | 引出方向のみ | ラインマーク+Spool#(移動方向:引出方向) |
| 9 | 通り芯寸法 | 文字情報編集 | 引出方向のみ | 通り芯寸法(移動方向:引出方向) |
| 10 | 溶接記号 | 文字情報編集 | 引出位置から任意 | 溶接記号(移動方向:引出位置から任意) |
| 11 | 部材寸法 | 文字情報編集 | 引出方向のみ | 部材寸法(移動方向:引出方向) |
| 12 | 配管中心寸法 | 文字情報編集 | 引出方向のみ | 配管中心寸法(移動方向:引出方向) |
| 13 | 根巻き寸法 | 文字情報編集 | 引出方向のみ | 根巻き寸法(移動方向:引出方向) |
画面構成
サポート図編集画面の構成は次の通りです。
| リボン | 編集操作の呼び出しがこの画面から直接実行可能です。 |
|---|---|
| Menuバー | 全ての編集操作がこのMenuバーから実行できます。リボンの「メニューバー」チェックボックスのOn/Offで表示/非表示切り替え可能です。 |
| ツールバー |
ツールバー上のアイコンをクリックするだけで編集機能を直接呼び出すことができます。 リボンの「ツールバー」チェックボックスのOn/Offで表示/非表示切り替え可能です。 |
| 図面編集領域 | サポート図を編集する画面領域です。 |
| ステータスバー | 各種メッセージを表示します。 |

リボンの構成

| パネル | コマンド | 機能 | 参照Page |
|---|---|---|---|
| ファイル | 開く | サポート図を開きます | 図面編集 |
| 保存 | サポート図を保存します | 図面編集 | |
| 印刷 | 現在表示しているサポート図を印刷します | 図面編集 | |
| レイヤ分け出力 | 現在表示しているサポート図をDXF/DWG出力します | 図面編集 | |
| 前の画面 | 複数選択編集している場合、前の図面に戻ります | 図面編集 | |
| 次の画面 | 複数選択編集している場合、次の図面に移ります | 図面編集 | |
| 表示 | メニューバー | メニューバーの表示/非表示をきりかえます | |
| ツールバー | ツールバーの表示/非表示をきりかえます | ||
| ステータスバー | ステータスバーの表示/非表示をきりかえます | ||
| クロスカーソル | クロスカーソルの表示/非表示をきりかえます | ||
| 背景色 | 背景色を白/黒で切り替えます | ||
| 全体表示 | 現在の表示領域に図面全体が入るよう拡大・縮小を調整します | ||
| BOX拡大 | 箱型指定して画面を拡大します | ||
| 拡大 | 画面を拡大表示します | ||
| 縮小 | 画面を縮小表示します | ||
| 復元操作 | 元に戻す | 直前の操作を元に戻します | Menu構成 |
| やり直し | 直前の操作をやり直す | Menu構成 | |
| 任意文字・図形 | テキスト | 立体組図内の機能と同一なので 13-15-x-x参照してください | 13-15 任意文字・図形(共通) |
| 引出線テキスト | |||
| 線分 | |||
| 円 | |||
| 円弧 | |||
| 長方形 | |||
| 訂番記号・雲 | |||
| 矢視 | |||
| コマ図 | |||
| 連続作成 |
Menu構成
メインMenu
メインMenuの各項目から呼び出される機能との関連は以下の通りです。機能の詳細については各機能の内容を確認して下さい。
コマンドIDはプログラム内部で使用、画面には表示されません。
MsuptGui画面のメインMenu
| Menu | Menu(2階層) | コマンドID | 参照Page | 機能 |
|---|---|---|---|---|
| ファイル(F) | Luを開く(O)... | ID_FILE_OPEN | Luを開く | Lu を開く |
| 図面出力(D)... | ID_FILE_EXPORT | 図面出力 | 図面出力-選択サポート図の出力(印刷/DXF/DWG) | |
| アプリケーションの終了(X) | ID_APP_EXIT | - | サポート図編集-終了操作 | |
| 編集(E) | 全図面選択(A) | ID_EDIT_ALL | 全図面選択 | サポート図編集-全サポート図の選択 |
| 図面編集(E)... | ID_EDIT_DRAWING | 図面編集 | サポート図編集-選択サポート図の表示 | |
| レイヤ設定(L)... | ID_EDIT_LAYER | レイヤ設定 | サポート図編集-選択サポート図のレイヤ設定 | |
| 図面設定(P)... | ID_EDIT_PROPERTY | 図面設定 | サポート図編集-選択サポート図のスケール設定 | |
| 初期化 | ID_EDIT_INITIALIZE | - | 編集機能-保存前の編集を全て戻す | |
| 表示(V) | メニューバー(M)... | ID_VIEW_MENU_BAR | メニューバー/Tool Bar | 表示-Windowの表示/非表示 |
| ツールバー(T)... | ID_VIEW_TOOLBAR | メニューバー/Tool Bar | 表示-Windowの表示/非表示 | |
| ステータスバー(S)... | ID_VIEW_STATUS_BAR | ステータスバー | 表示-Windowの表示/非表示 | |
| Ft-In設定 | ID_VIEW_UNIT_NOTATION_SETTING | Ft-In設定 | 表示-Feet-Inches表示設定 | |
| オプション(O) | 絞込み(F)... | ID_OPTION_FILTER | 絞り込み機能 | 表示-表示するサポート図の絞り込む |
| ヘルプ(H) | MsuptGuiのバージョン情報(A)... | ID_APP_ABOUT | - | バージョン-バージョン表示 |
SuptEditGui画面のメインMenu
| Menu | Menu(2階層) | Menu (3階層) |
コマンドID | 参照Page | 機能 |
|---|---|---|---|---|---|
| ファイル(F) | 図面を開く(O)... | ID_FILE_OPEN | 図面編集 | サポート図編集-図面を開く | |
| 図面の保存(S)... | ID_FILE_SAVE | リボンの構成 | サポート図編集-XMLファイル保存 | ||
| 前の図面(B) | ID_FILE_PREV | 図面編集 | サポート図編集-選択切替 | ||
| 次の図面(N) | ID_FILE_NEXT | 図面編集 | サポート図編集-選択切替 | ||
| 印刷(P)... | ID_FILE_PRINT | 図面編集 | 印刷-印刷 | ||
| 印刷プレビュー(V) | ID_FILE_PRINT_PREVIEW | 図面編集 | 印刷-印刷プレビュー | ||
| プリンターの設定(U)... | ID_FILE_PRINT_SETUP | 図面編集 | 印刷-プリンタの設定 | ||
| 図面の2D書式への出力(E) | レイヤ分け出力(L)... | ID_FILE_EXPORT_LAYER | 図面編集 | サポート図編集-レイヤ分けDWG/DXF出力 | |
| サポート図面編集の終了(X) | ID_APP_EXIT | リボンの構成 | サポート図編集-終了操作 | ||
| 編集(E) | 編集(E) | ID_EDIT_MARKEDITMODE | リボンの構成 | 編集機能-編集Modeの選択 | |
| 元に戻す(U) | ID_EDIT_UNDO | 図面基本操作 | 直前の操作を元に戻す | ||
| やり直す(R) | ID_EDIT_REDO | 図面基本操作 | 直前の操作をやり直す | ||
| 切り取り(T) | ID_EDIT_CUT | 図面基本操作 | 任意文字/図形の切り取り | ||
| コピー(C) | ID_EDIT_COPY | 図面基本操作 | 任意文字/図形のCopy | ||
| 貼り付け(P) | ID_EDIT_PASTE | 図面基本操作 | 任意文字/図形の貼り付け | ||
| 他の図面へ貼り付け(H) | ID_EDIT_PASTE_TO_OTHER | 図面基本操作 | 任意文字/図形を他の図面に貼り付け | ||
| 初期化 | ID_EDIT_INITIALIZE | 図面基本操作 | 編集機能-保存前の編集を全て戻す | ||
| 削除(D) | ID_EDIT_DELETE | 図面基本操作 | 編集機能-任意図形/文字の削除 | ||
| 発生(G) | 任意文字(T) | テキスト... | ID_PLOT_FREEMARKTEXT | 「13-15 任意文字・図形(共通)」の任意文字の配置 | 文字編集機能-任意文字(文字)の配置 |
| 引出線テキスト... | ID_PLOT_FREEMARKBALLOONTEXT | 「13-15 任意文字・図形(共通)」の任意文字の配置 | 文字編集機能-任意文字(引出線)の配置 | ||
| 線分... | ID_PLOT_FREEMARKLINE | 「13-15 任意文字・図形(共通)」の任意図形(線分)の配置 | 文字編集機能-任意図形(線分)の配置 | ||
| 円... | ID_PLOT_FREEMARKCIRCLE | 「13-15 任意文字・図形(共通)」の任意図形(円)の配置 | 文字編集機能-任意図形(円)の配置 | ||
| 円弧... | ID_PLOT_FREEMARKARC | 「13-15 任意文字・図形(共通)」の任意図形(円弧)の配置 | 文字編集機能-任意図形(円弧)の配置 | ||
| 任意マーク(K) | 長方形... | ID_PLOT_FREEMARKRECT | 「13-15 任意文字・図形(共通)」の任意図形(長方形)の配置 | 文字編集機能-任意図形(長方形)の配置 | |
| 訂番記号・雲... | ID_PLOT_FREEMARKREVISION | 「13-15 任意文字・図形(共通)」の任意図形(訂番記号・雲)の配置 | 文字編集機能-任意マーク(訂番記号・雲)の配置 | ||
| 矢視... | ID_PLOT_FREEMARKARROW | 「13-15 任意文字・図形(共通)」の任意図形(矢視)の配置 | 文字編集機能-任意マーク(矢視)の配置 | ||
| コマ図... | ID_PLOT_FRAMEDRAWING | 「13-15 任意文字・図形(共通)」のコマ図の配置 | 文字編集機能-コマ図の配置 | ||
| 表示(V) | メニューバー(M)... | ID_VIEW_MENU_BAR | リボンの構成 | 表示-メニューバーの表示/非表示 | |
| ツールバー(T)... | ID_VIEW_TOOLBAR | リボンの構成 | 表示-ツールバーの表示/非表示 | ||
| ステータスバー(S)... | ID_VIEW_STATUS_BAR | リボンの構成 | 表示-ステータスバーの表示/非表示 | ||
| 拡大/縮小(Z)... | 拡大(I) | ID_VIEW_ZOOM_IN | リボンの構成 | 表示-サポート図の拡大表示 | |
| 縮小(O) | ID_VIEW_ZOOM_OUT | リボンの構成 | 表示-サポート図の縮小表示 | ||
| 全体表示(A) | ID_VIEW_ZOOM_ALL | リボンの構成 | 表示-サポート図の全体を表示 | ||
| BOX拡大(B) | ID_VIEW_ZOOM_BOX | リボンの構成 | 表示-サポート図内の指定範囲の拡大表示 | ||
| 任意図形(F) | 円(C) | ID_VIEW_MARK_FREEMARKCIRCLE | リボンの構成 | 表示-円の表示/非表示 | |
| 円弧(A) | ID_VIEW_MARK_FREEMARKARC | リボンの構成 | 表示-円弧の表示/非表示 | ||
| 長方形(R) | ID_VIEW_MARK_FREEMARKRECT | リボンの構成 | 表示-長方形の表示/非表示 | ||
| 線分(L) | ID_VIEW_MARK_FREEMARKLINE | リボンの構成 | 表示-線分の表示/非表示 | ||
| コマ図(F) | ID_VIEW_MARK_FRAMEDRAWING | リボンの構成 | 表示-コマ図の表示/非表示 | ||
| 任意マーク(K) | 訂番記号・雲(V) | ID_VIEW_MARK_FREEMARKREVISION | リボンの構成 | 表示-訂番記号・雲の表示/非表示 | |
| 矢視(W) | ID_VIEW_MARK_FREEMARKARROW | リボンの構成 | 表示-矢視の表示/非表示 | ||
| 任意文字(T) | リボンの構成 | ID_VIEW_MARK_FREEMARKTEXT | リボンの構成 | 表示-文字の表示/非表示 | |
| クロスカーソル(I) | ID_VIEW_CROSSCURSOR | リボンの構成 | 表示-クロスカーソルの表示/非表示 | ||
| 背景色(G) | 白背景(W) | ID_VIEW_BGCOLOR_WHITE | リボンの構成 | 表示-背景色を白で表示する | |
| 黒背景(B) | ID_VIEW_BGCOLOR_BLACK | リボンの構成 | 表示-背景色を黒で表示する | ||
| ヘルプ(H) | サポート図編集のバージョン情報(A) | ID_APP_ABOUT | - | バージョン-バージョン表示 |
図面編集
図面基本操作
保存
文字情報の対話編集した情報を保存します。
-
操作方法
メインMenuの[ファイル(F)]-[図面の保存(S)...]を選択すると保存します。
編集終了
サポート図編集の操作を終了します。SuptEditGui画面が閉じます。
-
操作方法
メインMenuの[ファイル(F)]-[サポート図面編集の終了(X)]を選択します。
切り取り/コピー/貼り付け/他の図面へ貼り付け
切り取り、コピー、貼り付け、他の図面へ貼り付けが可能なのは「任意文字/図形」です。
「寸法」「高さ」等のモデルに関連する文字情報はできません
初期化
編集情報を全て初期化します。削除した文字情報も全て初期位置に現れます。
「任意文字・図形」はオプションの初期化設定に従って削除されます。
-
操作方法
メインMenuの[編集(E)]-[初期化]を選択します。
削除
選択した文字情報、任意文字/図形を削除します。
一度削除した文字情報を再度表示するには「初期化」が必要です
-
操作方法
削除したい文字情報、任意文字/図形を選択し、メインMenuの[編集(E)]-[削除(D)]を選択します。
文字情報編集
位置移動編集の基本事項
-
本体に紐づく文字・図形情報の移動
各文字情報には基準点が存在し、寸法等の物体に紐づく文字情報は、基準位置を移動できません。

※:本体に紐づく文字・図形情報は、引き出し位置が基準位置となり、引出反対方向への移動調整を行います。引出方向から逆への移動は出来ません。
-
本体から独立した文字・図形情報の移動
サポートスタイル、ノースマーク等は、サポート本体に紐づいた情報ではないため、位置を自由に移動できます。

上図では『スタイル』と『アタッチメント詳細図』の移動例。(他にも『U-ボルト穴詳細図』と『コメント』も移動しています)
※図番(配置No.、DOC.No)を変更しても編集情報は崩れることなく保持されます。
各種文字データの基準位置と移動
基準位置:
、移動対象図形:
内
アタッチメント詳細図(移動方向:任意)

U-ボルト穴詳細図(移動方向:任意)

各詳細図は独立して移動が可能
コメント(移動方向:任意)

スタイル(移動方向:任意)

北方向(移動方向:任意)

サポート高さ/サポート固定部高さ(移動方向:引出方向)

矢印向きに移動調整
基準点から、引き出し方向の反対側向きには移動不可
面取り記号(移動方向:引出方向)

矢印向きに移動調整
基準点から、引き出し方向の反対側向きには移動不可
ラインマーク+Spool#(移動方向:引出方向)

矢印向きに移動調整
基準点から、引き出し方向の反対側向きには移動不可
各ラインマーク、個別で移動
通り芯寸法(移動方向:引出方向)

矢印向きに移動調整
基準点から、引き出し方向の反対側向きには移動不可
溶接記号(移動方向:引出位置から任意)

引出位置から任意移動
部材寸法(移動方向:引出方向)

矢印向きに移動調整
引き出し方向の反対側向きには移動不可
配管中心寸法(移動方向:引出方向)

矢印向きに移動調整
基準点から、引き出し方向の反対側向きには移動不可
根巻き寸法(移動方向:引出方向)

矢印向きに移動調整
基準点から、引き出し方向の反対側向きには移動不可
